Bus Conversion Magazine Bulletin Board

Bus Discussion => Board Help => Topic started by: puff501 on August 28, 2017, 10:57:00 AM



Title: MCI with 6v92 no power, shift issues
Post by: puff501 on August 28, 2017, 10:57:00 AM
I'm Steve and new to this forum.
Currently I've been assigned to do "light maintenance" on our fleet of busses.  We have 8 right now, all old Greyhounds, 1994 MCI 12's I think, very high mileage machines.  
Anyway, we have 1 in particular which has very little power, and shifts way too late as I see it.  It takes off and accelerates slowly, and it is shifting into 3rd at about 43 mph and 4th, high gear, at 51/52.  So, it gets up there slowly and at the shift speeds, it seems like it is taching out whereby it will be at like 42 and I'm comeon, comeon shift, and she'll go into third and at 50 in 3rd, it's again the same just trying all it can to get to 51 so it can shift to high gear.  Our other busses shift much sooner, like 3rd at like 28 and 4th at like 44 but they all have decent power too.

Also on a road test yesterday, i got it to reach 65 mph, which I believe is what it is governed at twice from a dead stop, but when I turn around to come back to the yard, I was now in a headwind and I cold only get 55 out of it o a 5 mile level straightaway.  

So I ask for help on 2 things
1.  What can be done to get more power out of this bus?
2.  How can I or what is needed to get this bus to shift like the other busses in the fleet?

Any advice appreciated


Title: Re: MCI with 6v92 no power, shift issues
Post by: Nick Badame Refrig/ACC on August 28, 2017, 03:49:08 PM
Welcome puff501 ,

Have you replaced the fuel filters? Sounds like clogged filters!

Good Luck
Nick-


Title: Re: MCI with 6v92 no power, shift issues
Post by: PP on August 28, 2017, 04:21:08 PM
Welcome Puff501 and welcome to the forum. There are many knowledgeable people on this forum and I'm sure there will be more than one answer to your question. But I have to agree with Nick, it definitely sounds like fuel filter issue. Does it smoke black or white? If white it's your fuel filters. If black, it might be air filter. Those are the two places I would start checking if it were me. Good luck,
Will


Title: Re: MCI with 6v92 no power, shift issues
Post by: puff501 on September 02, 2017, 09:08:32 AM
OK I hear ya on the filters.  We have them all serviced at a shop but I don't necessarily trust them to do exactly what they are supposed to do or say they do.  It's one of them joints to me but I'm not the owner so it's not up to me.
I'll change the filters this weekend and I'll post results.

Thanks,
Steve