Bus Conversions dot Com Bulletin Board
December 22, 2014, 08:55:01 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: If you had an Online Subscription: It arrives at least two weeks before the First Class printed magazine.
   Home   Help Forum Rules Search Calendar Login Register BCM Home Page Contact BCM  
Pages: [1] 2 3  All   Go Down
  Print  
Author Topic: Redesigning bus generator bay ****PICS ADDED****  (Read 7069 times)
wal1809
Hero Member
*****
Offline Offline

Posts: 1339




Ignore
« on: August 08, 2010, 02:41:12 PM »

Well the only way to start this thread is to say this weekend was a rough bus trip.  Headed to Weatherford, Texas to put on a dog training clinic.  What should have been a 5 hour trip and plenty of time for a relaxing evening and a good night sleep, turned into a rough 10 hour trip.

To start I had to detour to Taylor to pick up a load of rattlers.  Got that out of the way and made it to Temple when the generator stopped.  The interior of the bus in seconds went to hotter than a hinge on the gates of hell.  Oh my God it was hot.  

I immediately suspected a filter was clogged on the gen.  I felt like am idiot because this was the first time I ran bio diesel in it.  I knew the build up crud was going to break up the first time I used bio diesel but I never dreamed it would do it that fast.  So I jumped on the Internet, found an auto part store in Temple,Texas and drove there.  Of course they did not have the right filter.  So I jury rigged a generic in line filter.  Gen fired right up and back on the road.  I had to back track 30 miles to get the right filters for the bus engine.  I thought if the little one just clogged then the big ones would too.  Got the filters and headed back north.

Got to the clinic location and went to bed.  Up at 4:30 AM and made coffee.  At 6:30 am the line was already forming.  Trained until noon and hit the road.  Just south of Fort Worth boom went the gen again.  Popped in another filter and it would not start.  Drove to a truck stop to get some shade on the bus and fuel.  The gen fired up.  I was still thinking it was the filters being clogged.

Made it to loop 340 in Waco and lost gen power again.  We parked under an over pass to shade the bus.  I started thinking there was no way a filter offer that fast.  It turns out the gen was getting hit and shutting off.  I was able to get it started and while in the shade it cooled itself down to normal temps.  We watched a movie while waiting on the cooler evening temps before heading home again.  9 hours to go a 5 hour trip.

The gen bay is set up with an air scoop on the drivers side to collect air and force it into the bay.  The gen radiator fan has been turned backwards to push air through the radiator and then out an expanded metal grate in the bay door on the passenger side.  Good theory but it does not work for these extreme Texas climate.

We had a strong east wind as we were northbound.  That would stop the hot air from exiting through the metal grate on the bay door.  On the way home we had a strong west wind which did the same thing.  I don't like having to stop and I dang sure don't like the heat in that rolling pill box.

My dirty water holding tank and fresh tank are in that bay as well.  I don't like the way they are set up either.  I want a gray tank, a black tank and a fresh tank all aluminum.  I want to also sent up the gen bay in a way that cools the gen no matter the temperature outside.
« Last Edit: August 10, 2010, 06:25:53 AM by wal1809 » Logged

1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com
luvrbus
Hero Member
*****
Online Online

Posts: 13132




Ignore
« Reply #1 on: August 08, 2010, 03:42:52 PM »

Wayne, the 1st thing you do is remove the scoop it pushes the air away because of the taper on a Eagle next pull the air in from the outside and exit through the bottom of the bays then it should work with out adding more fans.
If you want to remote mount the radiator with cage blower and close the hole in the door I'll help you it will make for a quieter generator those big holes in the doors make a generator loud.
 BTW what generator brand do have and you really don't want a aluminum water tank unless you never plan on a drink from it been there done that


good luck
Logged

Life is short drink the good wine first
wal1809
Hero Member
*****
Offline Offline

Posts: 1339




Ignore
« Reply #2 on: August 08, 2010, 04:58:52 PM »

HEllo luvrbus!  I have a 75 gallon plastic fresh tank that I could move from where it is now to make more room.  I didn't think about the fresh water tank tasting nasty.  We have a 400 foot water well here at the house and the water is better than bottled, taste wise anyway.  So I will take that advise and use it.

The brand gen is Kubota.  It is mounted on a slide out base.  What drives me absolutely batty is in order for the previous owner to aim the radiator at the expanded metal he turned the slide out base sideways.  The slide out is no longer usable.

I want to be able to slide the gen out to work on it/ clean it ect.  So I am very curious of bow to exhaust the radiator air out the bottom.  The muffler exhaust does go through the floor.

Also while we are at it,  the interior temps in the bus suffer drastically as we were driving. I have been tracking the holes amd plugging them.  Under the dash at the steering wheel is open for acces to wiring.  How did you close that off in your bus?  I know as I can feel it is sucking the cool air under the dash and out of the bottom of the bus by the wire panel under the driver window. 

Logged

1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com
Joe Camper
Hero Member
*****
Offline Offline

Posts: 666



WWW

Ignore
« Reply #3 on: August 09, 2010, 06:48:01 AM »

We have a Kabota too. We never overheat, regardless.

The gen is on a slide and it is mounted so that we are looking at the belts and pulleys, they are facing the door. The converter added a wood partition and the radiator is in that same bay on the other side of the partition.

The intake  for the radiator is the floor of the bay right at the door in front of the radiator approx 12 by 18.

It discharges out the floor on the other side of the radiator by the cooling blower into a baffle that blows the hot air away from the cold air intake, this is pretty important.

Are you recirculating the hot discharged air because of no baffle directing it away from the cold air intake on the discharge side?

Here are some photos

http://prevostmotorhomes.ning.com/forum/topics/a-generator-bay-rebuild

« Last Edit: August 09, 2010, 06:56:16 AM by Joe Camper » Logged

Signing off from Cook County Ill. where the dead vote, frequently.
eddiepotts
Sr. Member
****
Offline Offline

Posts: 446





Ignore
« Reply #4 on: August 09, 2010, 06:59:25 AM »

Wal, It sounds like I have the same set up on my Prevost. It does suck. One of the things I have done is wrap the exhaust in a fiberglass wrap, then bought cheap foil and put as many layers as I could then the fiberglass insulation wrap again on top of it. This brought the temps way down. My manifold temps were around 300*in the bay. Now I am looking into a fan shroud for the radiator. I think this will help allot. When I am in the bus My genny is always running. I have found I don't even need a hot water heater because of my aluminum tanks grabs so much of the heat in the bay. I did put a blower type fan in the bay by the water tank and it help push cooler air over to the genny. It really came down to turning off one of the three roof top air conditioners to keep it running while travelling. Also do not set the ac on full cold. Turn it up just a bit so they can still cycle and not just loading the genny up at all times. At my stops even if it is to go into the grocery store I open the bay door to let out some heat. The next bay over from my genny is where the original AC is. It also has a screen door. I thought about a squirrel cage fan pulling from this bay and sending it to the genny bay. I have a 21kw with 3 cylinder Kabota. I just think the Kabota is a little week for the genny running at full load with our Texas heat. And once again it's not the fact that it shuts down that makes me mad. It's all the complaining I listen to from the back like I don't know it's hot.
Logged
Joe Camper
Hero Member
*****
Offline Offline

Posts: 666



WWW

Ignore
« Reply #5 on: August 09, 2010, 07:17:56 AM »

If these gen are opporating and installed correctly they should run indefinitely, regardless.

It is not the unit......... it is either a bad component or an incorrect installation.

This hotter than normal summer is bringing out all the gremlins in many of the less that adiquate instalations but makes a good chance to update and improve.
« Last Edit: August 09, 2010, 07:21:05 AM by Joe Camper » Logged

Signing off from Cook County Ill. where the dead vote, frequently.
eddiepotts
Sr. Member
****
Offline Offline

Posts: 446





Ignore
« Reply #6 on: August 09, 2010, 08:59:42 AM »

Joe, I do agree with you. The only problem now is I open the bay and feel the sun on my head and close it Grin I really like what you did with yours and taking some ideas from it. My genny is mounted center in the bay so I see a real waste of space. I am thinking of moving it over like yours and making a remote radiator. I read allot on using thermal controls fans and what not but not sure if I want to get that sophisticated. I would think if the thermostat is working properly on the engine It would not matter if the electric fan ran full time. I know back in April I ran my genny for 4 days and you could hold your hand on the radiator now it would not run for an hour before shutdown.
Logged
wal1809
Hero Member
*****
Offline Offline

Posts: 1339




Ignore
« Reply #7 on: August 09, 2010, 10:16:33 AM »

If these gen are opporating and installed correctly they should run indefinitely, regardless.

It is not the unit......... it is either a bad component or an incorrect installation.

This hotter than normal summer is bringing out all the gremlins in many of the less that adiquate instalations but makes a good chance to update and improve.

I completely agree it is not set up right.  25 % of the radiator does not match up with the grate in the door.  That is putting me behind the 8 ball already. 
Logged

1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com
wal1809
Hero Member
*****
Offline Offline

Posts: 1339




Ignore
« Reply #8 on: August 09, 2010, 10:22:33 AM »

With the remote radiator set up do you have to disconnect the radiator hoses every time you slide the gen out?

Setting it up with a remote radiator-I like.  If I have to disconnect every time- I don't like, well maybe  I aint pondered it enough yet.
Logged

1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com
wal1809
Hero Member
*****
Offline Offline

Posts: 1339




Ignore
« Reply #9 on: August 09, 2010, 10:28:07 AM »

On the rear grate on the side of the bus is the air scoop I spoke of in the first post.  Behind it you can see the white tank.

Clifford will this hinder air coming into the bay?
  I circled it in black.  It sticks out about 4 inches.
« Last Edit: August 09, 2010, 10:33:47 AM by wal1809 » Logged

1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com
txjeff
Full Member
***
Offline Offline

Posts: 115





Ignore
« Reply #10 on: August 09, 2010, 03:15:52 PM »

Wal

My gauge for the gen was reading hot (220) on the last trip. I checked the kubota engine with the IR gun and found it to be running 185 or less everywhere. The interesting thing was there is a tee where the shutdown and temp sending unit are connected to the head, it reads 225 with the gun. Im not sure where your sending unit is located but it might be worth a look.

Jeff
Logged

73 MC-7combo
Brenham, Texas
luvrbus
Hero Member
*****
Online Online

Posts: 13132




Ignore
« Reply #11 on: August 09, 2010, 03:27:42 PM »

Take the scoop off Wayne it does no good it only harms the airflow drop a piece of yarn out a window while driving and you will see the airflow pattern it will go around that scoop hard to believe but that is the way it will work.
Wish you could post a picture of your generator head to show where the cooling intake and the discharge are located if between the engine and the head should be a easy fix.
Wayne you can turn the scoop around and move it 3 or 4 ft in front of the opening and it will help the airflow sounds dumb I know but air movement is a strange thing


good luck
« Last Edit: August 09, 2010, 03:52:31 PM by luvrbus » Logged

Life is short drink the good wine first
wal1809
Hero Member
*****
Offline Offline

Posts: 1339




Ignore
« Reply #12 on: August 09, 2010, 04:54:37 PM »

Thank you luvrbus I value your thoughts opinions and information.  I have 6 dogs coming to the house for training so I will only have time to photograph the gen.  Please check back tomorrow and I will have them posted.
Logged

1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com
Joe Camper
Hero Member
*****
Offline Offline

Posts: 666



WWW

Ignore
« Reply #13 on: August 09, 2010, 05:18:38 PM »

The radiator hoses have enough slack, they are looped and allow the slide out.

Isolating the rad from the gen will also make it quiter because you are now not exhausting the noise of the engine along with the hot air.

The partition between the gen and the radiator stops exactly 1 inch short of the backside of the bay door when it is closed, this scavenges some of the heet from the gen box without venting too much of its noise.

There is a square hole directly under the gen 6in by 6in this is for air intake a couple of them see those previous photos.

Our cooling fan/blower runs continous.
Logged

Signing off from Cook County Ill. where the dead vote, frequently.
Joe Camper
Hero Member
*****
Offline Offline

Posts: 666



WWW

Ignore
« Reply #14 on: August 09, 2010, 05:26:44 PM »

Doing what Loverbus suggested may be all you need  I would try that before you do anything.
Logged

Signing off from Cook County Ill. where the dead vote, frequently.
Pages: [1] 2 3  All   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!