Bus Conversions dot Com Bulletin Board
August 01, 2014, 05:29:21 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: If you had an E-Mag Subscription: The dog will not eat it.
   Home   Help Forum Rules Search Calendar Login Register BCM Home Page Contact BCM  
Pages: [1] 2 3  All   Go Down
  Print  
Author Topic: Radiator and Kubota engine repair services need in Las Vegas, NV  (Read 3524 times)
Sean
Geek.
Hero Member
*****
Offline Offline

Posts: 2545


'85 Neoplan Spaceliner "Odyssey"


WWW

Ignore
« on: February 20, 2012, 11:56:30 AM »

Folks,

I need recommendations for a decent radiator shop that can test and possibly re-core a small radiator on a Kubota-powered generator set, and also a shop that could, if needed, hoist the set out of the bus, pull the head, diagnose any issues found there, and install a new head gasket.  Both of these places need to be in or near Las Vegas, NV.

Reason:

As some of you may already know, we are in the Las Vegas area for the next three weeks.  While we are here, I have been helping friends and fellow bus nuts Ben and Karen with their problematic Kubota-powered Power Tech generator.  (Some of you may know Ben as the fellow who is converting a Flxible Starliner, and while that is being done they are living in a Prevost Liberty Classic Lady.)

I have the generator portion of the set, as well as the control system, working perfectly.  However, there are two issues, possibly related or possibly not.

The first issue is that after it has sat for a while, say overnight, the Kubota will overheat shortly after startup.  It would seem that air is ingressing into the system, and a giant air pocket at the thermostat housing (or maybe in the water pump?) is preventing coolant circulation.  Unsurprisingly, the overheat switch, attached to a cooling passage in the head, quickly reaches the set point and shuts the unit down.

Every time this happens, I am able to bleed the system (although sometimes it takes more than one try), refill it, and get the set started.  Once the system has been fully bled, the generator runs fine, will stay running for hours, and has good coolant circulation through the radiator.  Shutting it down and restarting it within a few hours is also usually successful, perhaps because it has not cooled far enough in the daytime temperatures for the pressure to drop sufficiently in the system to draw air into it.

In addition to lots of 15-year-old hoses and clamps, there appear to be a couple of pinhole leaks in the radiator itself.  Any of these might be the source of the air ingress, so we'd like to get the radiator tested and repaired or re-cored along with all the hoses changed out.  Thus the radiator shop recommendation.

The second issue is that, in doing this work, I have noticed the coolant has a slight brown tinge to it.  It is possible that this is just rust and/or dirt from years of neglect, or maybe adding red coolant to a green system, but it is also possible that it is due to products of combustion in the coolant, possibly indicative of a broken head gasket or worse.  If that's the case, it is also possible that this is the source of the gas bubbles in the cooling system.  I have recommended that he get the coolant tested, along with the oil.  If either reveals signs of cross-contamination, then we will need a qualified Kubota mechanic to pull the head and have a look.

Any and all suggestions, recommendations, and comments are welcome.  Post here or feel free to email or PM me.  We want to get this work done between now and around March 13, so that I can be available to go to the shop with him and talk to the techs.  Thanks.

-Sean
http://OurOdyssey.BlogSpot.com
Logged

Full-timing in a 1985 Neoplan Spaceliner since 2004.
Our blog: http://OurOdyssey.BlogSpot.com
Len Silva
Hero Member
*****
Offline Offline

Posts: 4083


Angle Parked in a Parallel Universe


WWW

Ignore
« Reply #1 on: February 20, 2012, 12:58:30 PM »

Does the unit have a coolant recovery system and have you checked it and the cap?

If it sucking air when it cools down because of an empty tank or bad hose, that could form a vacuum in the system which would pull in air.  If any part of the cooling system is higher than the fill cap that would cause the air bubble.  A bad check valve in the cap could force it to suck air from the smallest leak.
Logged


Hand Made Gifts

Ignorance is only bliss to the ignorant.
Gary '79 5C
Hero Member
*****
Offline Offline

Posts: 613




Ignore
« Reply #2 on: February 20, 2012, 01:09:48 PM »

Len,

Good suggestion, I have added a recovery tank, and changed out the cap. I was loosing coolant too much, too often. That has corrected my situation.

Sean,

Not sure if your genset was sourced from Wrico, but mine was from the PO, I have gotten great advice from Dick.

Is that small radiator worth "reworking", given labor rates it might be better to replace. (?) This comes reluctantly, from a very frugal engineer.

Good Luck.

Logged

Experience is something you get Just after you needed it....
Ocean City, NJ
Sean
Geek.
Hero Member
*****
Offline Offline

Posts: 2545


'85 Neoplan Spaceliner "Odyssey"


WWW

Ignore
« Reply #3 on: February 20, 2012, 01:40:00 PM »

Does the unit have a coolant recovery system and have you checked it and the cap?

Yes and yes.  I've checked all the obvious things.  The radiator is remote, and there is a small tank above the fan belt as well.  Each has a cap.  Radiator cap was bad, so we replaced; unfortunately, I could not source a 14 so replaced with a 13.  Cap on the other tank, which is on the return side, is an 11.  Both caps are functional now.

Quote
If it sucking air when it cools down because of an empty tank or bad hose, that could form a vacuum in the system which would pull in air.

Yes, I think that's what I said.  Which is why I want the radiator tested and all the hoses replaced, hence my request for a good radiator shop.

Quote
  If any part of the cooling system is higher than the fill cap that would cause the air bubble.  A bad check valve in the cap could force it to suck air from the smallest leak.

Again, cap has been replaced.  As far as I can tell, the cap is the highest point in the system, but I can't really see how Liberty ran all the lines.

Not sure if your genset was sourced from Wrico, but mine was from the PO, I have gotten great advice from Dick.

As I wrote, it is a Power Tech.  Wrico and Power Tech are competitors.  Also, this is an engine problem now, not a genset issue, so, while Dick certainly knows the Kubota, there is no reason why any other Kubota service tech could not handle these issues.  Dick's cooling system is a bit different as well -- Power Tech has this weird custom-made belt guard/expansion tank system over the fan belt.  I'm not quite sure what the purpose of having a tank in the return side is, but that's the way Power Tech does it.  They also have a weird custom extension over the thermostat housing, with a bleeder on it and a right-angle take-off for the coolant hose, replacing the stock Kubota thermostat housing cover with hose nipple.  Dick does not use any of these parts, so he would not necessarily be familiar with them.

Quote
Is that small radiator worth "reworking", given labor rates it might be better to replace. (?) This comes reluctantly, from a very frugal engineer.

Well, replacing it would be an option if it is a 100% standard size.  My experience with these sorts of generators is that the radiator hardly ever cross-references to anything you'd find in a radiator shop, and so re-coring is usually the answer.  But here is, again, where a good radiator shop will be able to help us.  We will go with whichever route is cheaper, for sure.

-Sean
http://OurOdyssey.BlogSpot.com
Logged

Full-timing in a 1985 Neoplan Spaceliner since 2004.
Our blog: http://OurOdyssey.BlogSpot.com
junkman42
Sr. Member
****
Offline Offline

Posts: 450





Ignore
« Reply #4 on: February 20, 2012, 01:54:53 PM »

Sean, simple thought from a simple man!  Red mud or red/brown coolant is quite often the result of someone using stop leak !  Many times stop leak plugs up radiator flues when air is present.  Just a thought, good luck.  John L
Logged
Van
Billy Van Hagen
Hero Member
*****
Offline Offline

Posts: 2337


89' Silver Eagle 15/40 6V92MUI Boulder City,NV




Ignore
« Reply #5 on: February 20, 2012, 03:07:33 PM »

just a shot. Performance radiator on arville, don't have the # at hand but check your v-mail for it. give Gary@B&B for shop suggestions, 702-873-4415 good luck!
Logged

If you are not living on the edge, then you're takin' up too much space!!!
luvrbus
Hero Member
*****
Online Online

Posts: 12106




Ignore
« Reply #6 on: February 20, 2012, 03:18:02 PM »

Why pull the head pressure test the head on the engine first if it doesn't hold pressure then pull the head,use a vacuum pump to pull the water through on a Kubota takes all the bubbles out and if he is using the wrong antifreeze they will make air bubbles repair the leaks and test IMO that will be what any honest shop will do, 

The odd color is probably from using 2 different types of antifreeze could be rust by not keeping the system maintained over the years

good luck 
« Last Edit: February 20, 2012, 03:57:15 PM by luvrbus » Logged

Live each day like it was your last,one day it will be
rv_safetyman
Hero Member
*****
Online Online

Posts: 2199


Jim Shepherd


WWW

Ignore
« Reply #7 on: February 20, 2012, 04:40:37 PM »

Sean, an antifreeze sample test might help with the engine decision.  A bad head gasket would probably put the soot level pretty high. 

When my first Series 60 went south (liners sank in block and let combustion past the head gasket), I had the antifreeze analyzed to confirm my worst thoughts about the problem.

Jim
Logged

Jim Shepherd
Evergreen, CO
85 Eagle 10/Series 60/Eaton AutoShift 10 speed transmission
Somewhere between a tin tent and a finished product
Bus Project details: http://beltguy.com/Bus_Project/busproject.htm
Blog:  http://rvsafetyman.blogspot.com/
blank
Hero Member
*****
Offline Offline

Posts: 1929




Ignore
« Reply #8 on: February 20, 2012, 07:56:26 PM »

  Just a thought, but likely most of the radiator shops are in the phone book or can be found online. Likely someone in the area knows generators or RV's who could recommend the best radiator shop.

  I'm with Clifford, do the simple stuff first before yanking the head off.

  Generally, rapid overheat from cold is a telltale sign of a failing thermostat. If it pushed coolant out it will suck air back in as soon as its shut down. If it were a head gasket one would expect it to show the problem continuously, not momentarily, and only after cold start up. Additionally, a head gasket leak would be leaking coolant into the oil or the cylinder, or both. Coolant in the oil would make a milky appearance. Coolant in the combustion chamber generally creates exteme hard starting (hydraulic lock), followed by thick steam like exhaust. Most auto parts stores sell the test kit to check for combustion byproducts in the coolant, though its known there for some false positives.
Logged
Sean
Geek.
Hero Member
*****
Offline Offline

Posts: 2545


'85 Neoplan Spaceliner "Odyssey"


WWW

Ignore
« Reply #9 on: February 20, 2012, 10:45:25 PM »

  Just a thought, but likely most of the radiator shops are in the phone book or can be found online.

Obviously, and I do know how to do that research.  My point in asking here was to hopefully get a recommendation (for or against) from other bus nuts based on personal experience.  I'd rather pick a shop from others' experience rather than from a phone book

Quote
Likely someone in the area knows generators or RV's who could recommend the best radiator shop.

Well, yes, but if I knew someone in the area who knows generators, I wouldn't be asking here.  As for knowing RVs, I generally don't trust conventional RV service establishments for anything -- if they can't look it up in the OEM documentation for a name-brand RV, they are usually no help and sometimes worse.

Quote
Generally, rapid overheat from cold is a telltale sign of a failing thermostat.

Sometimes, yes.  In this case, the problem happened with no thermostat in the housing at all -- apparently it had been removed due to failure on some previous occasion, and Ben had not gotten to installing the replacement, although he had it in his kit.  I opened the thermostat housing after the first failure as part of my diagnosis, cleaned everything up, and while I was in there I installed a brand new OEM Kubota thermostat, so I don't think the thermostat is the culprit here.

Quote
... If it were a head gasket one would expect it to show the problem continuously, not momentarily,

Well, that's my guess, too, which is why I said these issues may not be related.

Quote
... Additionally, a head gasket leak would be leaking coolant into the oil or the cylinder, or both.
...

Not necessarily -- it depends on exactly where the gasket is damaged/leaking.  It is possible for a leak to be only, say, between a cylinder and a cooling passage, but not an oil passage.  If the leak was minute enough, then normal coolant pressure might not be enough to force coolant into the cylinder, whereas combustion pressures could still force combustion gasses into the coolant.  That said, I think you are correct that if this was happening, then a gas bubble would form during operation that would almost immediately cause a shutdown, and we're seeing the unit run for hours without trouble once it is bled.

I am fairly convinced that the only real problem we have here is air ingressing into the cooling system during the cool-down process, most likely through old hoses or clamps, poor cap fit, or pinholes in the radiator.  The off color of the existing coolant is probably an unrelated issue, but I though it worth mentioning here.

Based on all the recommendations so far, we are going to get the cooling system work done at a local radiator shop, and send a coolant sample out for analysis.  We'll only pressure-test the head if that comes back with combustion products in it.

Would still like any recommendations for local radiator service, besides the one from Van whom we will call in the morning.  I am pretty convinced that the radiator will need to be replaced or re-cored; not only am I seeing pinhole leaks, but it's 15 years old and has been subjected to tap water and who knows what else -- if it's anything like mine was at that age, it's probably half blocked, too.  Plus I'd like a professional shop to backflush the whole system, replace all the hoses and clamps, and refill and bleed the system with a vacuum pump as Clifford suggests.

Thanks.

-Sean
http://OurOdyssey.BlogSpot.com
Logged

Full-timing in a 1985 Neoplan Spaceliner since 2004.
Our blog: http://OurOdyssey.BlogSpot.com
blank
Hero Member
*****
Offline Offline

Posts: 1929




Ignore
« Reply #10 on: February 21, 2012, 08:28:33 AM »


Quote
... Additionally, a head gasket leak would be leaking coolant into the oil or the cylinder, or both.
...
Not necessarily -- it depends on exactly where the gasket is damaged/leaking. 

  Not really. If there is a loss of coolant that put air into the system, that lost coolant had to go somewhere. Even if the cap was bad, or there were hose leaks, the only way to allow air into the system, is after an equivalent volume of coolant loss. If its not on the ground and isnt in the oil, its a pretty sure bet it went out the tail pipe. However...

  If its truly a closed system, the cap should vent into the overflow bottle, with the vent hose fully extended to the bottom of the overflow bottle, and fully immersed coolant. If the vent line sucks air after cool down, that air is going straight into the cooling system. If these Kubotas are real sensitive to air in the system it probably ddent take much. If its a custom setup, perhaps the bottle isn't large enough, the hose isnt fully down in the coolant, the hose may have a break or crack somewhere, etc.. I would inspect that area in great detail. Engines usually have to cool below 100F before the cooling system will draw back any significant volume from the overflow, after everything else has contracted. That may be why it doesnt show its ugly head after a few hours being shut down, but does after an overnight.

 

     

  I share your disdain with RV centers, however, most do not work on generators, they send them out to someone. A few calls to various shops and their recommendations should point you to someone honest. Notice I didnt say "qualified", lol.

  I would suggest a call to Wrico. That outfit seems to be the most highly respected shop in North America. While they certainly cannot fix your problem over the phone, they likely can give you much better suggestions of where to look, and may possibly know a good shop in that area. Another place would be Power Tech themselves. The few times I have spoke to them I found them very helpful.

  Also, pressurising the cooling system to 25 psi should find any leaks, block cracks, blown gaskets, or anything else than cant withstand the pressure.

 
Logged
luvrbus
Hero Member
*****
Online Online

Posts: 12106




Ignore
« Reply #11 on: February 21, 2012, 08:50:26 AM »

Sean is on the right track a call to Dick Wright about a Kubota engine problem would be a waste of time he just buys the complete engine he does no repairs doesn't have a clue except on his packages and before you guys jump on me Dick and I are friends and have been for a long time

good luck
Logged

Live each day like it was your last,one day it will be
Sean
Geek.
Hero Member
*****
Offline Offline

Posts: 2545


'85 Neoplan Spaceliner "Odyssey"


WWW

Ignore
« Reply #12 on: February 21, 2012, 09:44:52 AM »

... If its not on the ground and isnt in the oil, its a pretty sure bet it went out the tail pipe. ...

Ahh, I see I left out an important detail: it's on the ground.  Each time the system has overheated in this way, enough coolant blew out the relief to overflow the recovery tank, and we lost a cup or two every time.  After I bled the system, we'd then have to top up the radiator, making up for what was lost.

... a call to Dick Wright about a Kubota engine problem would be a waste of time he just buys the complete engine he does no repairs doesn't have a clue except on his packages ...

I agree with Clifford on this, as I wrote in my response to Gary above (http://www.busconversions.com/bbs/index.php?topic=22932.msg252083#msg252083).  Dick and I also go way back, and some of you may know that when I had to completely rewire my own Fidelity/Kubota set, I rewired it to Dick's standards, and also used his safeties, muffler, and mounts.  But he is a generator guy, not a mechanic, and there is no reason why he would be any more qualified to diagnose a cooling problem than a tractor dealer, and the latter is going to be easier to get to here in Vegas.

Power Tech has, indeed, been helpful, and some insight from them did help me to resolve the issue with the voltage regulator.  But here again, they are not going to be able to diagnose a cooling system from 3,000 miles away.  They could, perhaps, answer my question about why the weird two-tank arrangement, but that's largely irrelevant to the current problem.

Incidentally, I am rather unimpressed with Power Tech's controls.  In particular, the overtemp safety is not fail-safe, as it is, for example, in Dick's design.  So if the wire comes off the overtemp sensor, the safety is defeated and the set can overheat without shutting down.  Lots of things can cause a little wire like this to break -- on my own set, the wire to the temperature sender for the gauges broke from years of vibration -- and then you'd have no overheat protection without knowing it.  In addition to destroying an expensive genset, this kind of thing can lead to fire and the loss of the whole coach.  So shame on Power Tech for taking such a shortcut.

Similarly, whereas Dick's design uses a tiny handful of reliable and readily-available parts (two switches, two relays, two safeties, and a fuel solenoid), Power Tech uses a proprietary circuit board with four relays and a bunch of discreet components.  Add to that the weird belt guard and tank arrangement plus the funky extension above the thermostat housing, and now you've got a bunch of parts that can only be supplied by Power Tech themselves -- which is, perhaps, their intent.

I went through this same headache working on Chris and Cherie's Onan in Arcadia a couple months ago.  What ought to have been a simple circuit using a few discreet parts was instead printed on some proprietary Onan board, which now has failed in a way that can't easily be repaired.  Onan's way of locking you in.  I've suggested to them to ditch the Onan board and I would design them a start/stop system using just the pair of relays and switches, but they are preoccupied with other issues at the moment.

The more I work on other people's generators the greater my appreciation for my own ancient set, which has a completely mechanical governor and is transformer regulated.  Eventually my rings will wear out or perhaps the bearing in the generator head will go, but otherwise there's hardly anything electromechanical to break, and there's nothing to adjust.

-Sean
http://OurOdyssey.BlogSpot.com
Logged

Full-timing in a 1985 Neoplan Spaceliner since 2004.
Our blog: http://OurOdyssey.BlogSpot.com
luvrbus
Hero Member
*****
Online Online

Posts: 12106




Ignore
« Reply #13 on: February 21, 2012, 10:30:47 AM »

Sean, those guys at a trailer refrigeration place like Great Dane in Vegas are top notch on the Kubota engines if you can get one to look at it fwiw

good luck
Logged

Live each day like it was your last,one day it will be
rv_safetyman
Hero Member
*****
Online Online

Posts: 2199


Jim Shepherd


WWW

Ignore
« Reply #14 on: February 21, 2012, 10:46:57 AM »

Sean, the symptom of filling the overflow bottle and then running the antifreeze on ground sure sounds like my Series 60 problem where the liners sank in the block and let the combustion past the head gasket.

In the case of the Kubota, it probably does not have liners, but a blown head gasket would give the symptom you are describing.  The head gasket would have to be compromised between the cylinder and the water jacket for this to be the same problem.  The sure signal would be a grayish color to the antifreeze.  In my case, I drew some antifreeze out of the overflow and let it sit in a glass jar.  After about a day, the soot settled in the bottom and was very obvious.

May not be the problem, but the symptoms sure sound the same to me.

Jim
Logged

Jim Shepherd
Evergreen, CO
85 Eagle 10/Series 60/Eaton AutoShift 10 speed transmission
Somewhere between a tin tent and a finished product
Bus Project details: http://beltguy.com/Bus_Project/busproject.htm
Blog:  http://rvsafetyman.blogspot.com/
Pages: [1] 2 3  All   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!