Bus Conversions dot Com Bulletin Board
November 28, 2014, 01:44:34 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: This BB is intended for the sole purpose of sharing conversion and bus related information among visitors to our web site. These rules must be followed in order for us to continue this free exchange of info. No bad mouthing of any business or individual is permitted. Absolutely no items for sale are to be posted, except in the Spare Tire board. Interested in placing a classified or web ad, please contact our advertising dept. at 714-903-1784 or e-mail to: info@busconversions.com.

   Home   Help Forum Rules Search Calendar Login Register BCM Home Page Contact BCM  
Pages: [1]   Go Down
  Print  
Author Topic: Transmission oil light  (Read 309 times)
Purplewillie
Full Member
***
Offline Offline

Posts: 130





Ignore
« on: April 07, 2013, 12:30:29 PM »

I posted this on BNO as well,just looking for suggestions on both boards.
My trans oil light has been coming on every time I start the bus. Never came on when we picked the bus up or on the 2 day drive home. My bus has had a v730 put in years ago so I'm not 100% sure if its even connected to the transmission. Where would it connect to the trans?
Trans fluid level is full and my understanding of the transmission low oil light is that it shouldn't work until the trans is up to operating temps. Mine is coming on as soon as the 8v71 fires up, stays on for 45 minutes or so of driving then flickers and goes out.
Anyone have any ideas what I should be checking? Transmission has oil,seems to shift ok,65 + mph in high gear. Maybe a filter plugging up?
I'm stumped at the moment, I am accepting suggestions on things to check....
Thanks   Mark
Logged

Mark & Char
1976 P8M4905a 8v71 v730
British Columbia Canada
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!