inverter stopped working

(1/2) > >>

cody:
Got a question for the board, yesterday my inverter (Freedom model 10) started to surge it was going on and off, I shut off everything that was running and then shut down the inverter, thinking it would reset itself and left it off over night, this morning  it won't turn on, it's dead to the world, it has 2 reset breakers on the front of it but they arn't popped.  I checked the breakers in the fuse box and reset them just in case but no life.  I have the bus plugged into the outlet at home right now and all the circuits work off house power but the inverter is still dead.  Any ideas?  If it is dead, because it's probably on the small side for what should be in the bus, any recommendations for a replacement, I have the remote control panel for it and it would be nice if I could still use it.  cody

Tony LEE:
Poor connection on the 12V lead. As the load goes on, get voltage drop across the bad joint that shuts the inverter down on low voltage, voltage goes back up as soon as the load goes off, inverter switches back on and so on.

Or a high load on the mains side of the inverter that is triggering an overload or temperature protection that then resets allowing the inverter to start again.

What sort of surging - how often - etc.

cody:
It was pulsing, but I think I got it fixed, I called Heart and they said that it had probably lost it's memory and to restore the memory I would have to shut off the inverter, shut off the remote and then unplug the telephone type of cord from the back of the remote, then unplug the bus from shore power, then disconnect the negative cable from the battery, then leave it sit for at least 5 minutes.  While I was waiting I cleaned the battery terminals, then after about 15 minutes I hooked everything back up and it started up just fine.  The procedure was very simple and seemed to work, well worth noting, they said if it makes a practice of loosing it's memory tho, it should be replaced.  cody

Hartley:
Actually Cody, That was exactly what I was going to say.

Power it down, disconnect the battery cable and wait a little while and hook
it back up.

For some strange reason the Freedom series and my 458 series will freak out after working fine for months and needs to be reset, Pulling the power from it apparently resets whatever caused it to act up.

Mine went nuts one day, None of the remote buttons worked or the front panel buttons. I tried everything and then remembered the power down, It's been fine ever since... seems like I have to do that a couple times a year...dunno..

Dave....

Dallas:
Quote from: cody on November 16, 2007, 01:53:20 PM

<<<< they said if it makes a practice of loosing it's memory tho, it should be replaced.  cody >>>>



That's what Cat keeps saying about me!

DF

Navigation

[0] Message Index

[#] Next page