Bus Conversions dot Com Bulletin Board
October 21, 2014, 09:52:06 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: If you had an Online Subscription: It takes up much less space in your bus.
   Home   Help Forum Rules Search Calendar Login Register BCM Home Page Contact BCM  
Pages: [1]   Go Down
  Print  
Author Topic: Generator light on dash  (Read 1046 times)
tucsontattoo
Full Member
***
Offline Offline

Posts: 141


1962 4106


WWW

Ignore
« on: June 11, 2006, 10:00:00 AM »

 I have an V w/225 amp alternator. Gen lite stays on until engine RPM hits 1500 then go out and stays out even at idle. seems to be charging fine,I just find this odd.Can anybody tell me if this is normal or the why of this.  I seem to recall my old big truck w/V did the same thing

                          Just curious   Tucson
Logged

we do things three ways,good,fast or cheap. PICK TWO!
Busted Knuckle
Hero Member
*****
Offline Offline

Posts: 6447


6 Setras, 2 MCIs, and 1 Dina. Just buses ;D


WWW

Ignore
« Reply #1 on: June 11, 2006, 10:08:03 AM »

Tucson,
I don't know abouit on yer bus but on our MCI's the regulators have an adjustment screw and can be turned up or down to fix this. But on that same note I got one that we've tried to adjust but it doesn't help, but if ya turn on some kinda load marker lights, A/C, headlights anything at all the gen. light goes out! And as I was always told if it ain't broke, don't try to fixit!(come to think of it Dad still tells me that! LOL!)
Smiley Wink Cheesy Grin Shocked Cool Roll Eyes  KNUCKLE Roll Eyes Cool Shocked Grin Cheesy Wink Smiley
Logged

Busted Knuckle aka Bryce Gaston
KY Lakeside Travel's Busted Knuckle Garage
Huntingdon, TN 12 minutes N of I-40 @ exit 108
www.kylakesidetravel.net

Grin Keep SMILING it makes people wonder what yer up to! Grin (at least thats what momma always told me! Grin)
akroyaleagle
Hero Member
*****
Offline Offline

Posts: 507





Ignore
« Reply #2 on: June 11, 2006, 11:00:07 AM »

I believe this is normal with some altenators.
When I had mine rebuilt a few years ago it did that. It still does 10 years later.
I was told by several electrical wizards not to worry about it and I don't.
There is supposedly a diode that needs the rpm to excite.
Logged

Joe Laird
'78 Eagle
Huron, South Dakota
Bosshosssport96
Full Member
***
Offline Offline

Posts: 102




Ignore
« Reply #3 on: June 11, 2006, 12:05:14 PM »

Greg,thats normal,when the rpm hits 1350 you'll notice that the light goes off,same with my Cruiser...Frank
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!