Bus Conversion Magazine Bulletin Board
October 18, 2017, 05:15:28 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: If you had an Online Subscription: You can zoom in to make the text larger and easier to read.
   Home   Help Forum Rules Search Calendar Login Register BCM Home Page Contact BCM  
Pages: 1 [2]  All   Go Down
  Print  
Author Topic: 102A3 clutch issues  (Read 2497 times)
hargreaves
1987 MCI 102A3
Sr. Member
****
Offline Offline

Posts: 299





Ignore
« Reply #15 on: October 08, 2008, 10:04:03 PM »

Insert Quote
Sammy , thanks very much for the info. it was great. I've come to the conclusion that the pressure plate is old and stiff. I went through all the  adjustments that Sammy sent me. I get the required 1 3/4 in cable travel at the pedal and when the cable is disconnected at the trans. I get the same travel, but when I hook it all up and depress the clutch pedal I  only get 1 1/4 in. travel. This is not enough travel to apply  the clutch brake.

The pressure plate that is in the coach has a bolt that you depress and turn clockwise to get more freeplay, counterclockwise to decrease the freeplay. Mine seems to be stuck as When I tryed to adjust it I stripped the teeth off the adjuster, thats the kind of day I've been having LOL. There were enough teeth left to put it back together and lock it in place.
Logged

now as of Feb 2012 series 50 B400  . Sunshine Coast British Columbia
Pages: 1 [2]  All   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!